Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Smile Installing Sim City 3000 on Windows 7

    Hello there everyone, hope you're all having an absolutely fantastic day!

    I am currently trying to install my old copy of Sim City 3000 UK edition, but with little luck. Opening the launcher simply plays some music and nothing else. Opening setup.exe does nothing.

    I have tried using compatibility mode. I even tried opening it with my computer set to 800x600@16bit

    Any help will be very much appreciated. Thanks.

  2. #2
    Hey there!

    I had the same problem and found a solution that worked well for me.
    I downloaded the Building Architect which updates SC3000 to V 1.1
    (You also have to do this if you want to play it on Win XP)

    I play with highest resolution and in the Win 98 / 2000 compatibility mode.

    Good luck!

  3. #3

    Building Architect

    I tried running the building architect patch, but it stops midway through its routine because it cannot find SimCity 3000 on my computer. How did you get around this?

  4. #4
    I have Simcity 3000 Unlimited, and it runs fine on my Core i7 with Windows 7 Professional, just needs to be run as administrator to save cities into its default city directory.

    From what I understand, the executable for SC3K Unlimited is v 1.1, the same exe when 3000 is updated with building architect. Once you update, you have the same binary minus the additional graphics, modes, etc. so it should run. Some effort in this version was put toward NT compatibility.

    Alternatively, try compatibility mode for Windows 95/98.

  5. #5


    I have tried compatability mode AND the patch, and it still doesn';t work.

  6. #6
    I've got the same problem, autorun or launcher.exe just does sound and setup.exe does nothing at all.
    Even compatibility with windows-whatever- does not change anything.
    If I found the solution I will post it

  7. #7
    Ok, I copy-paste the content of the CD on my computer and launched APPS/SC3U.exe and let the CD in drive. No need of compatibility mode or "Run as Administrator".
    Now it works on a Windows 7 64bits

  8. #8
    hi there everybody
    iv jsut brought sc3k and trying to install it on windows7 it loads up i get to the main install page click the "install sc3k" get the disk icon then nothing?

    can anyone help?


  9. #9
    make sure to have all windows closed or else it wont work, thats what the problem was for me

  10. #10

    Angry Sim City 3000

    I am also trying to install it on my Gateway One pc w/Win 7. All I get is the opening screen and an error message "forget about it". What can be done about this? A $40 game is totally useless with the newer os.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts