Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 22
  1. #11

    Thumbs down

    Quote Originally Posted by lysernix
    Follow these steps:

    1) Install Sim City 4. When the game starts on completion, exit.
    2) (Optional) Install Sim City 4 Rush Hour. When the game starts on completion, again exit.
    3) Install the Sim City 4 Rush Hour Update from this URL: http://simcity.ea.com/update/index_update.php
    4) You may use a custom resolution by adding this to the shortcut:
    "C\Program Files (x86)\Maxis\SimCity 4\Apps\SimCity 4.exe" -CustomResolution:enabled -r1920x1080x32

    Adjust as needed.

    5) Right click the shortcut again, and go to compatibility Check Run As Administrator, Disable Visual Themes, Run in Compatibility Mode for XP Service Pack 2
    6) CLOSE ALL OTHER PROGRAMS NOTHING ELSE CAN BE RUNNING ON THE TASK BAR
    7) Run the program. It may drop you back to the desktop at this point, or if it is still going hit CTRL-ALT-DEL go to TASK MANAGER then Processes. Find the Sim City Process. Right Click the process and select "Set Affinity..." Uncheck all but one processor, so that one processor only can run the Sim City process.
    Click back into the game on the taskbar. During the loading sequence ("EA, Challenge Everything") it may continue to drop you to the desktop... don't worry... once the game actually starts (Region View) you'll be able to play just fine!

    Hope this helps someone...

    Yo wassup i did every step, btw running win x64,until i started it. it showed the bridge pic and then i quickly went to task manager and when i pressed set affinity it said denied cannot do this

  2. #12
    @lysernix Why didint i think of that before,anyway it works

  3. #13
    I am personally having trouble getting SC4 to work on my computer. It seems to install correctly but when I go to start it up I receive an "Access Is Denied" message.

  4. #14
    It's a menace on my PC too, I have 64 bit Win7.

    All I can see is the splash screen, and that's it. The game won't launch unlike as expected.

    How I get it to work is quite simply to change my system color debth to 16 bit.
    Alt-Tabbing breaks the game though.

  5. #15
    Hi, I recently (as in yesterday) tried to install simcity 4 on my acer aspire all in one. It's an intel i7 processor 2600S with nVidia gt420 graphics card. 1.5tb hard drive and 8gb ram. It's running windows 7 64-bit also. A friend told me that the game is too old, that my computer won't support it. But it's got more then the minimum specifications. My problem is that it won't install, it paused and crashed my computer after only using the first disc. On this computer and my laptop which also runs windows 7. Though my laptop is only a dual core processor. The only computer I have that ran it is my dual core 1.8 ghz processor running windows vista 32 bit. Should I just give up on installing it on this computer and wait til simcity 5 comes out?
    Last edited by Missdanielledwyer; 02-10-2013 at 08:40 PM. Reason: Didn't explain my problem when installing game

  6. #16
    Mayor of SimCity Forum Ken's Avatar
    Join Date
    Feb 2005
    Location
    Saco Maine
    Posts
    975
    Blog Entries
    1
    I run SC4 on laptop that runs Win7 64 bit on an i7 processor, however, you have to start it up using a special command line. I created a shortcut with this command:

    C:\Windows\System32\cmd.exe /c START "high priority sc4" /high /affinity 2 "C:\Program Files (x86)\Maxis\SimCity 4 Deluxe\Apps\SimCity 4.exe" -intro:off -w -CustomResolution:enabled -r1600x900x16

    And told it to start in this folder:
    "C:\Program Files (x86)\Maxis\SimCity 4 Deluxe"

    Here is a "decode" of the command line:

    C:\Windows\System32\cmd.exe /c START "high priority sc4" /high /affinity 2
    cmd.exe starts SC4 locking it to my #2 core (SC4 only supports one core), and set's its priority to high for that core.

    -intro:off: Turns off SC4 intro.
    -w: Starts SC4 in windowed mode.
    -CustomResolution:enabled -r1600x900x16: Sets SC4 resolution to 1600x900. You may need to change this to a lower standard resolution (e.g. 1024x768). If SC4 is crashing lower the resolution to 1024x768.

    Make sure you save frequently, because SC4 is more likely to crash on Win7 than it was on WinXP.
    Ken Barbalace - Mayor of SimCity Forum
    My Firefox Theme Classic Compact: Based onFirefox's default theme but uses much less window space
    My Google SketchUp 3D Warehouse collections

  7. #17
    But is that the same as just simcity 4. I don't have deluxe addition...and I can't even get it to install, let alone run...

  8. #18
    Mayor of SimCity Forum Ken's Avatar
    Join Date
    Feb 2005
    Location
    Saco Maine
    Posts
    975
    Blog Entries
    1
    You'd have to adjust the paths, but the basic command line should be the same. I can't say why you can not get it to install.
    Ken Barbalace - Mayor of SimCity Forum
    My Firefox Theme Classic Compact: Based onFirefox's default theme but uses much less window space
    My Google SketchUp 3D Warehouse collections

  9. #19
    Thanks for that I don't think I'll worry about it.

  10. #20
    Well, I came here looking all over for a solution; the weird part is, I had a different problem due to something I do with all games.
    But my problem could be your solution.

    Excerpt from another site:
    The problem people have with installing Simcity 4, Rush Hour or whichever, is they allow it to auto install in the C:\Program Files (x86) directory, as we know, any changes in this directory require admin authorization, and for some reason it just does not work well with Simcity 4.
    In short, most people install the game in the x86 folder; a lot of the time, this makes the game not work.
    Solution? Put it in regular Program Files, or like I did, your own folder (Program Files X in my case).

    However: Don't be an idiot like me. As far as I can tell, the CD was still trying to launch from the default location, and of course that wasn't working.
    Solution to this new problem: Go to the folder the game is installed in, then 'Apps', and make a desktop shortcut to 'Simcity 4.exe'.

    I hope this helps someone else!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •