Results 1 to 1 of 1
  1. #1

    Exclamation could not initialize direct draw

    so my old dell dimension 5000 got trojan and i finally got round to repairing it and wiping the hard drive. my other desktop is a mac so i can't play my sim city 4 deluxe edition anywhere else. it used to work fine on my dell but now when i tried to install and play it i managed to install it but when it came to opening the game this message came up, "Could not initialize direct draw". i don't see why there is this problem now as it worked fine before. can anyone help me?

    i'm using windows xp professional (changed to home edition as i thought that this could be the problem but it hasn't helped...) service pack 1a (now 2) and i have an intel pentium 4 chip.

    please help me
    Last edited by Tzveti; 06-07-2012 at 03:47 AM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts