Results 1 to 2 of 2
  1. #1

    simcity 4 deluxe doesn't launch

    I have simcity 4 deluxe edition for years now and it has always worked.
    But today I ran it a administrator and after he asked permission for running and I said yes, he did nothing at all.
    how can I fix that?
    by the way I'm not using a downloaded version, but I use the original cd

  2. #2
    I have the exact same problem. 4 years ago I got The SimCity Box and it always worked. Although I had to force it open by starting with disk one to get the launch menu and than switching to disk two. Other than that it always worked. Then I got a virus and I had to wipe my hard drive. Tonight I tried to reinstall it to get my NAM on. I tried running it multiple times, and every time I have tried to run it it just will not launch. I tried the trick I used many a year ago and it still did not work. Ive tried running in compatibility mode for Win XP and even Win 98, running as an administrator, nothing seems to work.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •